Menu

segunda-feira, 30 de abril de 2018

Multifuncional Epson com firmware free

Essa matéria trada de uma opção pessoal de cada um, não é paranoia xiita. Mas iremos ver nessa matéria como instalar uma impressora com utilização minima de firmware proprietário e dos pacotes lsb, da serie "Debian Free".










PostScript Printer Description



PostScript Printer Description (PPD) são criados por fornecedores para descrever todo o conjunto de recursos e capacidades disponíveis para suas impressoras PostScript.

O PPD também contém o código PostScript (comandos) utilizado para invocar recursos para o trabalho de impressão. Desta forma, PPDs funcionam como drivers para todas as impressoras PostScript, fornecendo uma interface unificada para as funcionalidades e características da impressora.



Epson com drive PPD


Ao instalar a impressora sem a presença de repositórios ou driver proprietários, você tem uma lista de impressoras que possuem drivers abertos e drivers PPD.

Selecione Epson.







Na próxima tela selecione a sua impressora ou um modelo próximo ao seu, no meu caso a l355 não tem ainda, escolhi a l310.




Impressora instalada e usando o driver PPD.




Scan da pagina de teste da impressora.






Scanner


O Scanner não teve acordo e fui obrigado a utilizar o plugin iscan-network-nt da Epson que são proprietários


Mas mesmo ele sendo proprietário já temos o lado positivo na impressora, você não precisa radicalizar em ser 100% livre, mesmo porque se quiser ser deve sair da internet kkkkkkkkk

Para o scanner entre no link abaixo, busque pelo modelo da multifuncional e baixe só o drive para ele, não use o da impressora se conseguiu resolver com o PPD.









Instale normalmente executando o script install.sh




Driver instalado.





OBS: Segundo a Epson só os plugins são proprietários, caso alguém conheça uma alternativa aberta deixe seu comentário.

Um outro ponto positivo é para usuários Debian, na sua versão Stretch o pacote lsb foi removido dos repositórios e os drivers proprietários dependem do lsb, para o seu uso você precisa usar repositórios do Debian jessie, com o PPD nada disso é necessário. 

Donate - Contribua para a melhoria do nosso trabalho!!














3 comentários:

  1. Entrei para lhe agradecer pela dica. Ha dias sem imprimir com a atualização pro 18.04, agora o computador do trabalho já está funcionando! Valeu mesmo

    ResponderExcluir