Menu

quinta-feira, 25 de janeiro de 2018

spectre-meltdown-checker no Debian, Ubuntu e derivados

O verificador spectre-meltdown-checker acaba de chegar em seu repositório oficial.
Confira nessa matéria.








spectre-meltdown-checker


Agora você não precisa mais fazer o download de pacotes de fora do seu repositório para verificar as suas vulnerabilidades Intel.

O spectre-meltdown-checker faz a verificação de:


CVE-2017-5753 [bounds check bypass] aka 'Spectre Variant 1' - Difícil exploração pelo atacante.

CVE-2017-5715 [branch target injection] aka 'Spectre Variant 2- Difícil exploração pelo atacante.

CVE-2017-5754 [rogue data cache load] aka 'Meltdown' aka 'Variant 3- Fácil exploração pelo atacante.


O resultado do teste é apresentado como na imagem abaixo.







Como podem ver na imagem, a vulnerabilidade mais fácil de ser explorada, já está corrigida.

As demais é aguardar que a Intel libere um patch descente nos próximos dias.


Disponível para:

Debian Stretch/backports - Veja como habilitar Debian Backports

Debian testing ( Buster )

Ubuntu Bionic ( 18.04 )


Instalação


Para instalar abra o terminal e de o comando abaixo para o seu sistema operacional.


Debian Stretch/backports


sudo apt install -t stretch-backports spectre-meltdown-checker


Debian testing ( Buster )

Ubuntu Bionic ( 18.04 )


sudo apt install spectre-meltdown-checker

Como usar


Para fazer a verificação, de o comando abaixo no terminal.


sudo  spectre-meltdown-checker







Donate - Contribua para a melhoria do nosso trabalho!!










Nenhum comentário:

Postar um comentário