Menu

quarta-feira, 25 de outubro de 2017

Emulador Super Nintendo para Debian, Ubuntu e derivados

Outro vídeo game que marcou época o Super Nintendo, se você quer relembrar e jogar seus antigos games, leia essa matéria.







Super Nintendo




O emulador que iremos instalar é o Snes9x-gtk disponível por flatpak via flathub.




Caso ainda não esteja com seu sistema preparado para a instalação de flatpak, abra o seu terminal e siga as instruções.

OBS: No Ubuntu habilite o repositório universe em "Programas e atualizações".


Agora sim podemos instalar, de o comando abaixo no terminal.

sudo apt install flatpak gnome-software-plugin-flatpak

Repositórios


Para adicionar os repositórios do flatpak de os comandos abaixo.

flatpak remote-add --from gnome https://sdk.gnome.org/gnome.flatpakrepo

flatpak remote-add --from gnome-apps https://sdk.gnome.org/gnome-apps.flatpakrepo

flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

Instalação



Para instalar o Snes9x-gtk, de o comando abaixo no terminal.


flatpak install flathub com.snes9x.Snes9x

Feita a instalação você precisa das roms dos jogos, não irei postar aqui para evitar problemas, mas você pode facilmente as encontrar no Google pesquisando por

PACK ROMS SUPER NINTENDO


Tendo conseguido suas roms, abra o Snes9x-gtk e navegue até a pasta onde você as colocou, feito isso selecione um jogo e click em "Arquivo > Open Rom Image ...

Para executar o programa use o comando



flatpak run com.snes9x.Snes9x






 Navegue até o seu diretório de roms e seçecione uma.




Agora é só jogar :)





Um pequeno vídeo para vc matar a saudade antes de instalar o seu emulador.




Outra opção de instalação é do seu repositório oficial, para isso basta dar o comando abaixo no terminal.

sudo apt install zsnes

Que seria essa versão.




Donate - Contribua para a melhoria do nosso trabalho!!









6 comentários:

  1. Oi, tentei instalar o zsnes no debian 9, mas dá o seguinte erro:
    O pacote zsnes não está disponível, mas é referenciado por outro pacote.
    Isto pode significar que o pacote está faltando, ficou obsoleto ou
    está disponível somente a partir de outra fonte

    E: O pacote 'zsnes' não tem candidato para instalação

    ResponderExcluir
  2. Boa noite eu consegui instalar mas a velocidade está muito rápida. Alguém sabe como resolver. Não dá pra brincar assim :-(

    ResponderExcluir
    Respostas
    1. Verifique as configurações, esperimente resetar elas ou alterar

      Excluir
  3. Ola o meu eu installei certinho mais não da som!
    da esse erro ó: SDL sound driver initializing...
    --> (Frequency: 32000hz, Latency: 16ms)...Failed

    ResponderExcluir
  4. Verifique as configurações de som do aplicativo.

    ResponderExcluir