sexta-feira, 10 de março de 2017

Grub-customizer no Debian

O grub-customizer é um programa destinado a configuração do grub, seu gerenciador de boot do computador.










Grub Customizer é uma interface gráfica para alterar as configurações do grub2/burg.

OBS: Nessa matéria iremos usar uma PPA que fornece apenas o pacote em questão, mas caso não goste, fique totalmente a vontade para não fazer.

Atualizado em 29/10/2017


Para instalar abra o terminal e de os comandos abaixo na sequencia.

su

Adicione o repositório da versão compativel ao Debian stretch.

echo "deb http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu xenial main" >> /etc/apt/sources.list.d/grub-customizer.list

Instale o complemento para add a chave de segurnça do repositório.

apt install dirmngr

Instale a chave de segurança.

apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys A8AA1FAA3F055C03

Atualize o apt.

apt update

Instale a dependência  libssl1.0.0 que só se encontra nos repositórios do Jessie.

Use o comando para a sua arquitetura para fazer o download d dependência.


Para amd64 ( 64 bits )

wget http://ftp.us.debian.org/debian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u6_amd64.deb

Para i386

wget http://ftp.us.debian.org/debian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u6_i386.deb

Instale a dependência.


 dpkg -i libssl1.0.0_1.0.1t-1+deb8u6_*.deb

Instale o gru customizer.

apt install grub-customizer


Feita a instalação abra o  Grub Customizer.

Aguarde todas as entradas dos sistemas operacionais e programas serem carregados.




Na guia "Configurações Gerais" aconselho não alterar " Parâmetros do kernel"




Na guia "Configurações da aparência" você da uma perfumada no Grub.

Com tudo pronto click em Salvar.




 Donate - Contribua para a melhoria do nosso trabalho!!










6 comentários:

  1. Respostas
    1. https://linuxdicasesuporte.blogspot.com.br/2014/05/grub-customizer-no-ubuntu.html

      Excluir
  2. Não funcionou no meu debian 8. deu pacote quebrado.

    ResponderExcluir
    Respostas
    1. Poste a saída completa do erro, para poder ver como resolver

      Excluir
  3. Maravilha. Se esta mensagem de erro não existisse,
    "Depende: libssl1.0.0 (>= 1.0.0) mas não é instalável"
    Impossível instalar esta lib.
    Obrigado pela "DICA".

    ResponderExcluir
    Respostas
    1. Instale a dependência manualmente, essa é só uma da centena re pacotes removidos do Stretch.

      Excluir