Menu

quarta-feira, 3 de outubro de 2018

xfce4-weather-plugin não altera a localização no Debian Stretch

O applet de meteorologia do XFCE4 no Stretch não consegue localizar regiões diferentes da automática, confira nessa matéria como contornar esse erro.









Erro no xfce4-weather-plugin



O Applet de meteorologia do XFCE4 no Debian Stretch está com bug na lib libweather.so, o que já foi corrigido na versão 0.8.10-1.

Não funciona a busca por regiões como na imagem.







Mas não da para instalar a versão corrigida que é a do Debian Buster devido a dependências, a solução é usar apenas a lib do Buster.

Para facilitar a adição da lib corrigida, eu fiz o download do pacote com a corrigida e upei a lib no dropbox, mas se você preferir fazer tudo vc mesmo fique a vontade e baixe o .deb aqui, ou siga a matéria.



Resolvendo o problema


Remova o applet do seu painel dando click direito nele e depois em Remover.






Abra o terminal e de os comandos na sequencia.


Log como root

su 

Faça um backup da lib original 

mv /usr/lib/x86_64-linux-gnu/xfce4/panel/plugins/libweather.so /usr/lib/x86_64-linux-gnu/xfce4/panel/plugins/libweather.so.old 

Entre no dir da lib 

cd /usr/lib/x86_64-linux-gnu/xfce4/panel/plugins/ 

Baixe a lib do buster 

wget https://www.dropbox.com/s/bixzbpxult0erri/libweather.so

Pronto adicione o applet novamente ao painel e use que a pesquisa de regiões está funcionando normalmente.


.

O lugarzinho quente da peste esse Rio kkkkkkkkkkkk






Donate - Contribua para a melhoria do nosso trabalho!!













Nenhum comentário:

Postar um comentário