sexta-feira, 7 de julho de 2017

WPS Office no seu Debian, Ubuntu e derivados

WPS Office é uma suite de escritório proprietária, com visual estilo MS Office, além de alta compatibilidade ao MS Office, se é o que procura, leia essa matéria.







O WPS é um software proprietário, isso significa que você não tem liberdade alguma nele, no que diz respeito ao software livre ou aberto, se presa por liberdade use o LibreOffice.

WPS Office






Compatível com o Microsoft Office Suporta PPT, DOC, DOCX, XLS e XLSX Salvar documentos como PDF.

Destaques do  WPS Office


Compatível com Fedora, CentOS, OpenSUSE, Ubuntu, Mint, Knoppix e muito mais

Suporta sistemas de 32 e 64 bits

Totalmente compatível com o Microsoft Office

Verificação ortográfica agora disponível em mais de 10 idiomas diferentes



OBS: O WPS é escrito em QT, portanto se você usa ambiente gráfico que não seja KDE, instale o qt4-qtconfig com o comando abaixo.

sudo apt install qt4-qtconfig

Abra o qt4-qtconfig no menu Configurações > Configurações do Qt4

Configure para GTK+ em "Select GUI Style", em seguida vá ao manu "File" e salve.




Isso é para se evitar o erro reportado pelo membro da comunidade Lucas Augusto

lucas@debian-lucas:~$ wps
/usr/bin/wps, linha 38: 13405 Falha de segmentação ${gInstallPath}/office6/${gApp} ${gOptExt} ${gOpt} "$@"



Instalação


Iremos instalar a ultima versão estável da suite WPS 10.1.0.5707~a21.

Para a instalação abra o terminal e de os comandos abaixo.

mkdir wps-tmp

cd wps-tmp

Escolha a versão apropriada ao seu sistema, amd64 = 64 bit ou i386 = 32 bit.

Caso não saiba a arquitetura do seu sistema, o comando abaixo ira informar.

uname -r

Versão amd64

Erro de dependência relatado pelo membro da comunidade Ewerton Urias, por precaução, instale a dependência libpng12-0

Para sistema amd64 - 64 bit de o comando abaixo no terminal para fazer o download.

wget http://ftp.us.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb 

De o comando abaixo para instalar a lib.

sudo dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb


Download do WPS com o comando abaixo.

wget http://kdl1.cache.wps.com/ksodl/download/linux/a21//wps-office_10.1.0.5707~a21_amd64.deb -O wps-office.deb

Download das fonts com o comando abaixo.

wget http://kdl.cc.ksosoft.com/wps-community/download/fonts/wps-office-fonts_1.0_all.deb -O fonts.deb

Para instalar os pacotes que fizemos o download, de o comando abaixo.

sudo dpkg -i *.deb

Apagando os downloads do wps com o comando abaixo.

cd ; rm -fr wps-tmp

Versão i386

Erro de dependência relatado pelo membro da comunidade Ewerton Urias, por precaução, instale a dependência libpng12-0

Para sistema amd64 - 64 bit de o comando abaixo no terminal para fazer o download.

wget http://ftp.us.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_i386.deb

De o comando abaixo para instalar a lib.

sudo dpkg -i libpng12-0_1.2.50-2+deb8u3_i386.deb

Download do WPS com o comando abaixo.

wget http://kdl1.cache.wps.com/ksodl/download/linux/a21//wps-office_10.1.0.5707~a21_i386.deb -O wps-office.deb

Download das fonts com o comando abaixo.

wget http://kdl.cc.ksosoft.com/wps-community/download/fonts/wps-office-fonts_1.0_all.deb -O fonts.deb

Tradução para a interface


wget http://repo.uniaolivre.com/packages/trusty/main/wps-office-mui-pt-br_1.1.0-0kaiana1_all.deb -O ptbr.deb


Para instalar os pacotes que fizemos o download, de o comando abaixo.

sudo dpkg -i *.deb

Apagando os downloads do wps com o comando abaixo.

cd ; rm -fr wps-tmp

Corretor ortográfico

Escolha o seu idioma português.

PT_BR


Para instalar o corretor ortográfico para pt_BR.

Entre no diretório do corretor ortográfico.

cd  /opt/kingsoft/wps-office/office6/dicts/

Faça o download.

sudo wget http://wps-community.org/download/dicts/pt_BR.zip -O pt_BR.zip


Descompacte o arquivo que fez o download.

sudo unzip pt_BR.zip

Exclua o download.

sudo rm -fr pt_BR.zip

PT_PT


Para instalar o corretor ortográfico para pt_BR.

Entre no diretório do corretor ortográfico.

cd  /opt/kingsoft/wps-office/office6/dicts/

Faça o download.

sudo wget http://wps-community.org/download/dicts/pt_PT.zip -O pt_PT.zip

Descompacte o arquivo que fez o download.

sudo unzip pt_PT.zip

Exclua o download.

sudo rm -fr pt_PT.zip

Configurando o corretor ortográfico


Abra 0 WPS writer e navegue

Revisar > Corretor ortográfico > Definir idioma, selecione o corretor da sua língua.





WPS Writer




WPS Presentation




WPS Spreadsheets





Remoção

Caso resolva desinstalar o wps de o comando abaixo no terminal.


sudo apt remove --purge wps-*

Limpe o diretório do programa.

sudo rm -fr /opt/kingsoft




OPINIÃO PESSOAL, eu não troco o LibreOffice por nenhuma outra suíte de escritório :)


Donate - Contribua para a melhoria do nosso trabalho!!














Um comentário:

  1. um problema sério que ele tem é que ele não funciona com macros, já o libreoffice sim, funciona com macros

    ResponderExcluir