sexta-feira, 14 de julho de 2017

VirtualBox no Debian 10 Buster

A saga VB x Debian continua heheheh, dessa vez o problema é referente ao virtualbox no Debian Buster, leia essa matéria e veja como resolver.






Como já sabem o Virtualbox não está na stable e nem na testing, só tem na versão unstable, o problema é que também está apresentando o erro abaixo.




A unica forma de resolver o problema é usando o virtualbox diretamente da oracle, para isso iremos usar o repositório dela.

Abra o terminal e de os comandos para adicionar o repositório a sua sources.list.

Log como root.



su


Adicione o espelho.


echo "deb http://download.virtualbox.org/virtualbox/debian stretch contrib" > /etc/apt/sources.list.d/virtualbox.list

Adicione a chave.


wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | apt-key add - ; wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | apt-key add -


Atualize o apt.


apt update


Verifique as versões disponíveis e escolha a que deseja instalar.


apt search virtualbox-

Atualmente teremos 3 versões:

virtualbox/unstable 5.1.22-dfsg-3

virtualbox-5.0/unknown,now 5.0.40-115130~Debian~stretch

virtualbox-5.1/unknown,now 5.1.22-115126~Debian~stretch




Remoção


Antes de instalar a nova versão, remova a anterior com problema.

apt remove --purge virtualbox*

Remova os residuos.

apt autoremove

Instalação


Iremos instalar a mais recente do repositório da oracle stretch, que atualmente é a virtualbox-5.1.

No terminal de o comando abaixo.


apt install  virtualbox-5.1

 Problema resolvido.




Tudo funcionando perfeitamente e na ultima versão do VirtualBox.




 Donate - Contribua para a melhoria do nosso trabalho!!









Nenhum comentário:

Postar um comentário